5.7.515
microsoft
Microsoft rejected the message because your domain does not meet its required authentication level for bulk senders.
Usual cause: Microsoft expects SPF, DKIM and DMARC to all pass for domains sending in volume.
Microsoft rejected the message because your domain does not meet its required authentication level for bulk senders.
Usual cause: Microsoft expects SPF, DKIM and DMARC to all pass for domains sending in volume.